We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 03:43 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:30 EDT
Monitoring
Some services are experiencing delays due to an ongoing AWS infrastructure issue affecting multiple providers. Impact:
Store Data Sync - Experiencing delays Events Processing - Experiencing delays Email Sends - Experiencing delays
What We're Doing: Our teams are working closely with AWS and continuing efforts to stabilize the platform and reduce latency, but we expect customers to continue to see periods of elevated latency and increased error rates until services are fully restored.
Posted Oct 20, 2025 - 14:38 EDT
This incident affects: Web Application, Automations, Reporting, Link Shortening and Redirection, Email Delivery, SMS Delivery and Cloud Infrastructure (Event pipeline, CDN (Cloudfront), Cloudflare CDN/Cache, DNS Servers).