Downtime due to AWS outage
Incident Report for Remarkety
Resolved
The underlying infrastructure issue has been fully resolved, and the system is operating normally.
Posted Dec 08, 2021 - 00:58 EST
Monitoring
AWS has updated that a fix has been implemented on their end. Although not officially resolved, we have been seeing normal application performance for the past 2 hours. We are continuing to monitor the system.
Posted Dec 07, 2021 - 17:19 EST
Update
We are seeing improvement in link redirection and overall app performance.
However, AWS has not fully resolved the outage and so our engineering team is still monitoring.
Posted Dec 07, 2021 - 16:52 EST
Update
We have identified an additional impact on email and SMS links, which intermittently lead to a "504 Gateway Time-out" page.
This is again due to the same AWS outage (https://www.theverge.com/2021/12/7/22822332/amazon-server-aws-down-disney-plus-ring-outage).
To clarify, AWS is Amazon's cloud, which powers a large part of the internet, as well as Remarkety's own servers. Our application relies on several AWS services for hosting, files, as well as link redirection.
Posted Dec 07, 2021 - 13:54 EST
Identified
We are currently experiencing various issues due to an AWS outage.
This outage is currently impacting:
- Uploading and downloading files
- Sending newsletters via email and SMS
We are further assessing the impact on other parts of the system.
Posted Dec 07, 2021 - 13:26 EST
This incident affected: Web Application, Automations, Reporting, and Link Shortening and Redirection.